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1.0 Novaduino® Display User Manual 
 
This manual outlines the interfaces and electrical design of the Novaduino® Display, enabling users to 
develop software or enhance hardware capabilities for creating customized electronic devices. 
 

2.0 Novaduino® Display PCBA Overview (NRL1000014rC) 
 
Novaduino® is a powerful, customizable platform for creating microcontroller-based Color Display 
projects. It works with a Feather*-compatible processor (not included) and includes a Graphic 2.4-inch 
Color LCD with a resistive-touch panel as well as files for 3D-printing your own case. Optional control 
buttons, a multi-directional navigation switch, and a rotary encoder may also be added.  
 
The platform is also built for easy expansion: the display board connects to additional components via 
two sturdy 40-pin connectors and a large 100mm x 120mm Proto Expansion Card (see KIT002). Design 
details are also available so that you can design your own expansion card. 

 
 

 
Figure 1. Novaduino® Display front view with all optional controls installed 
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Figure 2. Novaduino® Display back view 

 
 
3.0  Novaduino® Display Features and Interfaces 
 
Key Features of NRL1000014RevC Novaduino® Display PCBA 
 

• A 2.4-inch TFT LCD 320x240 IPS Display with Resistive Touchscreen  
o  [4DLCD-24320240-ips-rtp from 4D Systems] 

• Modular Expansion via 2x40 pin reliable connectors and a 100 mm wide expansion PCB 
assembly. The Prototype Expansion Card is available for bread boarding your circuits. 

o  [KIT002 or NRL1000013RevB from Nova Radio Labs LLC] 
• Customizable Controls with up to 5 front panel buttons, a rotary encoder, and a 5-way multi- 

directional navigation switch. All are high quality components. These are optional components 
that are available from Nova Radio Labs or other sources. 

o [TL1105SPF160Q Tact Switch from E-Switch] 
o [PEC12R-3220F-S0024 Encoder w/ 24 detent and SPST center button from Bourns] 
o [JS5208 multi-directional 5-way navigation switch from E-Switch] 

• Micro-SD Card Socket connected to the Feather Processor via SPI bus for additional storage. 
• USB-C Interface Connector for power and optionally also for data. For Data connection to the 

USB connector on the front panel please purchase one of the following: 
o [“USB micro-B Jumper Kit” if your Feather has a USB micro-B connection] 
o [“USB-C Jumper Kit” if your Feather has a USB-C connection] 

• Support for your choice of Feather Processor, including Adafruit Feather and Spark Fun Thing 
Plus - processor modules that can be programmed in Arduino, microPython, CircuitPython and 
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other languages. (KIT001 does not include a Feather Processor, this must be purchased 
separately) 

o Support for Wi-Fi, Bluetooth, and LoRa radio through selection of Feather form-factor 
modules. 

o Support for Li-Ion Batteries via the Feather processor. Most Feather processors also 
provide Li-Ion Battery charging. 

• A Key-Scan and Rotary Encoder Processor that provides key scanning for all the tact switches, 
the 5-way navigation switch, as well as the rotary encoder reading so that you don’t need to 
worry about skipped or multiple-count increments. The ATtiny1626 processor is pre-
programmed and provides its reading to the Feather processor via the TWI(I2C) bus whenever it 
detects a change. [at TWI/I2C address 0x40] 

• On board resistive touch controller with TWI(I2C) bus interface to the Feather Processor. 
o [TSC2007 from Texas Instruments at TWI(I2C) address 0x48] 

• Power Enable Switch 

• I2C/TWI/QWIIC*/Stemma-QT* connector allows easy connection to a wide choice of sensors 
and compatible hardware modules. The included TWI(I2C) bus pull-up resistors can be solder 
bridged-in if needed. 

• Power LED. This LED can be disconnected and repurposed to a GPIO pin if desired. 
• Red/Green/Blue LED connected to D13 on the Feather Processor. 

o [WS2812] 
• Front Panel Pass-through hole – accommodates an RF SMA connector on the Proto Expansion 

Card. May also be used for other types of connectors mounted to an Expansion Card. 
• 3D-Printable Case Options and compatibility with Hammond metal enclosures. 

o Front Bezel STL file for 3D printing or a pre-printed Front Bezel may be purchased. 
o 40 mm case w/integrated back panel STL file for 3D printing or a pre-printed case may 

be purchased. 
o 120mm case STL file for 3D printing or a 1455N12xx metal case from Hammond may be 

purchased.  
▪ Back Panel STL file for 3D printing or a pre-printed Back Panel may be 

purchased. This fits either the 120mm 3D printed case or the Hammond case 
o Nav Switch Cap STL file for 3D printing or a pre-printed Nav Switch Cap may be 

purchased. 
o Sensor Cover STL file for 3D printing or a pre-printed Sensor Cover may be purchased. 

This holds a 1” x 1” or smaller module onto the back of the 40 mm case. We use it to 
isolate the temperature/humidity/pressure sensor from the internal electronics. 

o Customizable Faceplate – both STL and f3d files are provided so that you can 
completely customize a Faceplate with your own design, labels, logos, and name as you 
desire. CNC, laser engrave, 3D-print or add your own graphics. 

• Circuit Design Features also include: ESD protection diodes, Isolatable Chassis and ground 
system, Chassis/shield connection to metal cases, all lead free components, and a 4-layer PCB 
with EMC design in mind (not yet certified.) 
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4.0 Novaduino® Display Block Diagram 
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Figure 3. Novaduino® Display Block Diagram 

 
 
 
 
 
 

 



6/23/2025 Novaduino® Display User Manual 
    NOVA RADIO LABS LLC 

_____________________________________________________________________________________ 

  

REV1.2 7 

©2025 Nova Radio Labs LLC 

5.0 Feather Socket and Power 
 

5.1 Feather Processor and Socket 
 
The Feather Processor system from Adafruit was chosen for Novaduino® because of the wide variety of 
processors that are available. Novaduino® has been tested with the Adafruit SAMD21 Feather M0 
processor running at 48 MHz, the Adafruit SAMD51 Feather M4 processor running at 120 MHz, and with 
the SparkFun Thing Plus SAMD51 processor running at 120 MHz. Future testing is planned with the 
processors shown in the table below. 
 
Table 1. Feather Processor Modules 

Processor Supplier Part number Processor/Clock 
speed 

note 

Feather M0 Adafruit 2772 or 3403 Cortex®M0/48 MHz stocked by Nova Radio 
Labs 

Thing Plus SAMD51 SparkFun DEV-14713 Cortex®M4+/120 MHz stocked by Nova Radio 
Labs 

Feather M0 WiFi Adafruit 3044 Cortex®M0/48 MHz 
Supports: 2.4 GHz Wi-Fi 

stocked by Nova Radio 
Labs 

Feather M4 Adafruit 3805 Cortex®M4+/120 MHz stocked by Nova Radio 
Labs 

Feather RP2040 Adafruit 4884 two Cortex®-M0+/ up 
to 133MHz 
 

Not tested yet, but 
should work with 
Novaduino® 

Thing Plus RP2040 SparkFun DEV-17745 two Cortex®-M0+/ up 
to 133MHz 
 

Not tested yet, but 
should work with 
Novaduino® 

Thing Plus STM32 SparkFun DEV-17712 Cortex®-M4/up to 168 
MHz 

Not tested yet, but 
should work with 
Novaduino® 

Feather STM32F405 Adafruit 4382 Cortex®-M4/up to 168 
MHz 

Not tested yet, but 
should work with 
Novaduino® 

Feather RP2350 Adafruit 6000 Dual M33 core/up to 
150 MHz 

Currently in Test 

Thing Plus - ESP32-
S2 WROOM 

SparkFun  LX7/up to 240 MHz 
Supports: 2.4 GHz Wi-Fi 

Not tested yet, but 
should work with 
Novaduino® 

Thing Plus ESP32-C6 DEV-22924 WRL-15663 RISC-V/up to 160 MHz 
Supports: 2.4 GHz WiFi 
6, Bluetooth® 5.3, 
Zigbee and Thread 
(802.15.4), 

Not tested yet, but 
should work with 
Novaduino® 

Adafruit ESP32 
Feather V2 with 
w.FL Antenna 
 

Adafruit  
5438 

ESP32 Dual core 
240MHz Xtensa®   
processor. 
Integrated 802.11b/g/n 
HT40 Wi-Fi. 
Integrated dual mode 
Bluetooth (classic and 
BLE) 

Not tested yet, but 
should work with 
Novaduino® 
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-Most any Feather form-factor processor that has the Feather pinout should work. Software changes may be required. 
-Almost any processor can be mounted to the Novaduino® Proto Expansion Card and drive the Display and controls through the backplane 
connectors. Logic level translators may be required. 
-Nova Radio Labs is not responsible for Processor performance and reliability. 

 

5.2 Processor Software 
  
Feather Processors support Arduino programming, C/C++, MicroPython,  CircuitPython*, or other 
languages supported by the processor manufacturer. We provide demonstration code written in 
Arduino C. Please see the software section later in this document or see 
https://github.com/NovaRadioLabs . 
 

5.3 Processor Mounting Options 
 
There are several methods for attaching the Feather processor to the Novaduino® Display board. We do 
not provide the Display board with pre-soldered headers to ensure you have maximum flexibility in your 
design.  
 

1. The most typical mounting method involves soldering female headers (one 16-pin and one 12-
pin) onto the Display board and stacking headers on the Feather processor. 

 
Other methods for mounting the Feather processor to the Display board include: 
 

2. Utilizing a 16-pin and a 12-pin male header to solder the Feather processor permanently to the 
Display board. 

3. Using a female header on the Display board and male headers on the Feather processor. 
4. Mounting any compatible processor to the Novaduino® Proto Expansion Card, which can drive 

the display and key interfaces over the backplane. 
 

The first method provides maximum flexibility by allowing direct connections to the Feather processor 
using breadboard jumper wires or by stacking Feather Wings directly onto the processor. 
 

 
Figure 4. Feather mounting method 1, most flexible but tallest option 

 

https://github.com/NovaRadioLabs
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The second method offers a minimum height solution for a compact device but makes changing the 
Feather processor very challenging. However, components or wires can still be soldered to the Feather 
pins if necessary. Feather Wings will need to be mounted to the Novaduino® Proto Expansion Card or a 
custom Expansion Card. 
 

 
Figure 5.  Mounting method 2, also showing a Real Time Clock module and a USB data cable kit 

 
The third method reduces some height while allowing easy replacement of the Feather processor, 
though it restricts direct connections to soldering components or wires to the Feather pins, as in the 
second method. Additional circuitry, including Feather Wings, can always be incorporated using the 
Novaduino® Proto Expansion Card or a custom Expansion Card. 
 

 
Figure 6. Mounting method 3, male headers on Feather module 

 
The fourth approach entails leaving the processor slot on the Novaduino® Display PCBA unpopulated 
and instead installing a processor onto a Novaduino® Proto Expansion Card. This configuration 
accommodates a wide range of processors, including Feather processors, Raspberry Pi running Linux OS, 
ESP32, Teensy processors operating at speeds up to 600 MHz, or even a Single Board Computer. 
Additionally, as the Display PCBA does not host a Feather processor to step down voltage from 5 volts to 
3.3 volts, it is necessary to provide a 3.3-volt supply to the Display PCBA via the expansion connectors 
from the Expansion Card. 
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Figure 7. Mounting method 4 using a Novaduino®Prototype Expansion Card with a processor 

 
 

5.4 Power Supply 
 
The Novaduino® Display board provides 5 Volt power to the Feather module through the USB-C 
connector. The Feather module’s regulator IC then provides 3.3 volts back to the Novaduino® Display 
board and all its components. The Feather module can also be connected to a LiPo battery that will 
power the Feather and the Novaduino®. The LiPo battery is charged through the Feather charging 
circuitry whenever power is provided through the Novaduino®   USB-C connector.  
 
Power can also be provided to the Novaduino® Display PCBA and the Feather through the native Feather 
USB connector. This is usually only used during programming of the Feather processor. Never connect 
both USB connectors at the same time. 
 
Most Feather processor boards can deliver up to 500 mA at 3.3 V (please verify your own chosen 
Feather’s capability). The TFT LCD display uses about 100 mA with full brightness of the backlight and 
consumes less current when the backlight is dimmed using a PWM port from the processor. Be careful 
not to exceed the 500 mA limit. 
 
If more than 500 mA is required, 5 Volt power can be supplied to the Novaduino® Display board (and 
subsequently to the Feather Module) through the backplane connectors J2 and/or J4. The optional 
Novaduino® Expansion Prototype Card (KIT002) can be populated with a USB-B connector to supply 5 
Volts to the entire system. Or a custom power supply circuit can be built onto an Expansion Card. 
 
For interface purposes, the Novaduino® uses 3.3 Volt interfaces, not 5 Volts. Do not connect 5-volt 
signals to the Feather interfaces to avoid failure of the Feather module and the LCD display. If a 5-volt 
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interface signal is needed, use a level shifter IC. Some examples are the 74LVC245 or the bi-directional 
level shifter chip with 4 channels TXB0104 (see Adafruit 1875 or SparkFun BOB-11771) or with 8 
channels TXB0108 (see Adafruit 395 or SparkFun BOB-19626). These are not recommendations, please 
do your own research. 
 
The power-enable switch disconnects the Feather EN line from ground to enable the voltage regulator 
on the Feather processor module. This same signal is also connected to an N-channel MOSFET (Q1) that 
turns on when the PWR_EN signal goes high and thus allows current to flow through the Power 
indicator LED turning it on. The PWR_EN signal line may be cut at JP1 to allow the user to connect the 
D2 LED buffer to a GPIO pin on the processor to use for other purposes. After cutting the JP1 jumper, 
connect the PLED pad on the PCB to a free digital pin on the Feather processor. 
 
 

 
Figure 8. Power LED can be re-purposed by cutting JP1 
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Figure 9. To use the power LED for other purposes, cut JP1 and connect to PLED pad 

 
 
The Color RGB LED is a WS2812B device with a single wire serial interface connected to Arduino Pin D13. 
Code examples for driving this RGB LED are discussed below in the Software section. 
 

 
Figure 10. RGB LED circuit 

 
 

5.5 LCD BACKLIGHT 
 
The 2.4-inch TFT LCD has 4 backlight LEDs in parallel that are buffered from the Feather processor by an 
N-channel MOSFET. The input to the backlight buffer is connected to Arduino Feather pin A2. Pin A2 can 
be used like a digital pin simply by asserting it High to turn the backlight on or low to turn the backlight 
off. Or pin A2 can be used as a PWM analog pin to vary the brightness and power consumption of the 
TFT LCD. The LCD is the major power-consumer on the Novaduino® Display board, when full on it 
consumes about 100 mA from the 3.3-volt supply. This can limit battery life if not moderated by 
reducing the brightness with a PWM signal.  
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Figure 11. LCD Display Backlight Buffer 

 
 
 

5.6 VREF strap, Chassis/Ground straps, and 5v Vusb straps 
 
Jumpers are provided on the PCB to allow customization of the VREF voltage that is currently connected 
to the 3.3 Volt supply, or chassis to ground connections for optimizing EMC issues, or separating the 5V 
supply lines from the Vusb supply line connections if desired. All these jumpers are connected by default 
but may be cut as needed. 
 
 

6.0 USB Data Interface 
 
Power is supplied to the Feather processor via the USB-C connector on the Novaduino® Display as 
explained earlier, however USB data pins are not connected through the Novaduino® PCB. This allows 
maximum flexibility in selecting the USB data source options.  
 
If programming through the Novaduino® Display board USB-C connector is desired or if an application 
requires a USB data connection, an optional USB jumper cable kit may be purchased. This twisted-pair 
jumper cable connects the USB serial data signal to the Feather USB connector. The jumper can be 
connected to either 1) the Novaduino® Display USB-C connector (via the D+ and D- pads near the USB-C 
connector) or 2) the USB connector on the optional Novaduino® Expansion Prototype Card (via the D+ 
and D- pads near the USB-B connector).  
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Figure 12. The USB Jumper Cable Kit installed for USB data 

A 3rd method of connecting USB data to the Feather mounted on the Novaduino® Display board is 
through 2 jumpers and over the backplane. Connect the first jumper on the Prototype Expansion Card 
between the D+/D- pads near the USB-B connector and the D+/D- pads near J10 that is connected 
internally to backplane connector J2. Next connect a USB male Jumper Kit to the D+/D- pads on the 
Novaduino® Display board above the P2 connector. This method provides USB data through the USB-B 
connector on the Prototype Expansion Card. 
 

7.0 Color TFT IPS Resistive Touch 240x320 LCD Display 
 
The 2.4-inch TFT LCD used in the Novaduino® NRT1000014RevC is a 4DLCD-24320240-RTP-IPS from 4D 
Systems. Cheaper displays are available, but these displays have reliability testing behind them and have 
good availability.  
 
The display is connected to the Feather socket and to the backplane connector J2 via the SPI_0 bus. The 
SPI bus is also used for the uSD card socket and may also be used with other applications on Expansion 
Cards by multiplexing through additional CS (chip select) signals.  
 
Dedicated LCD control lines are connected as shown in the Table below. 
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Table 2. LCD Connections 

Name Schematic name Feather 
(Arduino) 
Pin 

Logic Levels Comment 

Back Light  DISP_BL A2 high = on, low = 
off (into buffer, 
Q1) 

May Pulse Width Modulate to 
lower power consumption 

Display Chip 
Select 

DISP_CS! D6 Low = selected, 
high = not selected 

The display is selected for 
communication over the SPI bus 
when this is asserted low. 

Display Reset DISP_RST! A5 Low = reset It is important that the LCD driver 
software reset the LCD during 
initialization. (A5 is used like a 
digital port rather than analog) 

Data/Command DISP_DC D5 Low = Data 
High = Command 

The D/C signal tells the driver IC 
whether the incoming data is a 
command or is display data. The 
display driver code takes care of 
this. 

  
 
 
The 4DLCD-24322400-RTP-IPS TFT LCD from 4D Systems uses the ST7789V driver IC, however earlier 
versions of this display module were delivered with the ILI9341 driver chip instead. All our software 
examples have a #define variable at the top of the program listing that should be set to the proper 
driver chip number. 
 
A complete command and data sequence for initializing the display is provided in the 4DLCD-24322400-
RTP-IPS data sheet, however one of the advantages of using the Arduino Core software is access to its 
great library system that contains ST7789V and ILI9341 display drivers. We use the Adafruit display 
drivers as can be seen in our code examples. This driver gets the display up-and-running but additional 
software is needed to draw text and objects onto the display, we use the Adafruit GFX software for this 
purpose. Code examples will be shown later. 
 
 

8.0 Touch Controller 
 
The Novaduino® Display board uses the TI TSC2007 Resistive Touch Controller IC. This IC is connected to 
the X and Y lines of the resistive touch screen on the LCD. The IC provides a small source voltage to the 
resistive touch screen and senses the output voltage from the resistive voltage divider that is formed 
when one touches the screen. This voltage is digitized by Analog to Digital converters on the IC and then 
the converted 12-bit values are sent to the main processor (the Feather Processor) whenever a “touch” 
is sensed. When a “touch” is sensed by the IC it notifies the main processor by lowering the signal on 
PENIRQ! which is connected to digital pin D9 on the processor. The main processor can either poll pin D9 
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continuously looking for this low signal or it can sense an “interrupt” when this signal goes low. In either 
case, when D9 goes low, the main processer uses the TWI(I2C) bus to read the X and Y and Touch-
Pressure(Z) values from the TSC2007 chip at default address 0x48. One may change the address to 0x49 
by soldering jumper JP5 (A0), or to 0x4A by soldering jumper JP6(A1), or to 0x4B by soldering both JP5 
and JP6. 
 
 
 

 
Figure 13. Resistive Touch Screen controller 

Software demonstrations and examples of how to read the touch screen values are discussed in the 
Software section below. 
 
 

9.0 Key-Scan and Encoder Processor 
 
The 5 buttons (SW1, SW2, SW3, SW4, and SW5), the rotary encoder, and the multi-directional 
navigation switch are all scanned by the Keyscan Processor, an ATtiny1626 on the Novaduino® Display 
board.  When a key press or encoder rotation is sensed, the pre-programmed Keyscan Processor 
performs switch de-bouncing, reads the button number or rotation direction and stores the value in a 4 
Byte buffer. The key processor then sends a 500 microsecond positive pulse on the KBD_INT line 
connected to the main processor pin D12 to indicate that the key buffers are ready to be read over the 
TWI(I2C) bus at address 0x40.  
 
 In response to the Keyscan Processor interrupt signal, KBD_INT, on pin D12, the Feather processor 
reads the 4 bytes of buffered data over the TWI(I2C) interface. Keyscan data is buffered in four 8-bit 
integer (int8_t) buffers. The first 2 buffers contain the button number repeated in both buffers. The 
second 2 buffers contain either a +1 for a right rotation or a -1 for a left rotation of the encoder 
repeated in both buffers. The data is currently just repeated across the 2 buffers to allow a small degree 
of error checking of the data if desired. In future releases of the Keyscan software we may add a CRC for 
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error checking the data. Each time a button is pressed, the button number (1 to 11) is captured in each 
of the 1st two buffers and the rotary encoder value is reset to zero in the 2nd  two buffers, and then the 
interrupt line is pulsed. When the rotary encoder is sensed, the left(-1) or right(+1) value is captured in 
the 2nd two buffers and the 1st two buffer values are cleared, and then the interrupt line is pulsed. 
 
Code examples are provided and discussed in the Software section. 
 

 
Figure 14. Novaduino® Keyscan and Rotary Encoder Interface Processor Circuit 

 
 
 

10.0 Micro-SD Card 
 
The micro SD socket accepts a standard micro SD card. The card is written to and read over the same SPI 
bus used for the LCD Display but has its own chip select line connected to the Feather Processor pin A4. 
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Figure 15. Novaduino® micro SD card interface circuit 

 
 

11.0 Expansion Capability 
 
The P4 connector on the backplane Expansion Card interface has been designed to be similar to the pin 
assignments of a 40 pin Raspberry Pi interface connector with a few exceptions. The exceptions for the 
Feather version of the Display Board are indicated on the diagram below.  
 
The P4 backplane connection provides all the signals necessary to drive the display, access the Keyscan 
Processor, and read the touchscreen processor from a control processor on the Expansion Card if 
desired. 
 
Some of the pins are not connected on this version of the Novaduino® Display Board since the Feather 
format does not support them. These are planned for future versions of the Novaduino® Display with 
more powerful processors. Future Nova Radio Labs and custom Expansion Cards may only need to 
connect to P4. 
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Figure 16.  P4 Backplane Connections 

 
 
The P2 connector on the backplane Expansion Card interface provides USB connections, Feather power 
and control lines, and future SPI_2 bus, I2C_2 bus, and GPIO lines. The added power pins also reduce IR 
drops for higher current applications. 8 pins are also set aside for a high-speed bus on future 
Novaduino® designs. These 8 pins may, for example, accommodate Ethernet, PCIe, QSPI, I2S, etc.... 
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Figure 17. P2 Backplane Connections 

 
 
A Prototype Expansion Card is available (KIT002 from Nova Radio Labs) for use with Novaduino® Display 
PCBA via P2 and P4 connectors.  It also supports Arduino boards, Feather modules, and breadboard 
circuits and integrates nicely with the 120 mm case options. 
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Figure 18. Novaduino® Prototype Expansion Card, see KIT002. Accommodates an Arduino board or 

Feather devices and breadboard circuits. 

 
 
 
 

12.0 Novaduino® Display Demonstration Software 
 
To get you up-and-running with the Novaduino® Display board, we have written a demonstration 
program that provides Open Source (under the MIT Software License 
(http://opensource.org/licenses/MIT)) code examples. This code exercises the LCD Display, the 
touchscreen controller, an interrupt interface to the Keyscan Processor, the RGB LED, and the micro-SD 
card. This code is available on GitHub at    NovaRadioLabs/Demo-A_Novaduino_Display . 
 
You may also want to download and try out our other code examples for the Novaduino® Environment 
Sensor Kit or the Novaduino® Ultrasonic Car Parking Assistant Kit available at the same GitHub location. 
You can expand your Novaduino® Display to make these kits by simply adding the corresponding 

https://github.com/NovaRadioLabs/Demo-A_Novaduino_Display
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sensors. Or you can purchase the Novaduino® Environment Sensor KIT005 or the Novaduino® Ultrasonic 
Car Parking Assistant KIT006 from our website. 
 
 

12.1 Download and Set up the Arduino IDE 
We use the Classic Arduino IDE, version 1.8.19, that can be downloaded at www.arduino.cc. You 
can try the web version or the version 2.0 Arduino IDEs, but we have not tested those with the 
provided program code.  
 
__ Download and install the Arduino IDE. 
 

12.2 Adding Adafruit and SparkFun Board Scripts to the Properties tab 
 
Our demonstration code draws from libraries from both Adafruit and SparkFun as well as several 
of the built in Arduino libraries. The following is the procedure for installing these libraries. 
 
__ Open the Arduino IDE and go to the preferences under File>Preferences and see the 
“Settings” tab. 
Note the location of your Sketchbook, you’ll need to know that later. 
We suggest turning-on line numbers. 
 
__ In the editable one-line block labeled “Additional Boards Manager URLs:” add the following 
lines for board managers for Adafruit Feather boards and for SparkFun Thing Plus boards, 
separated by commas as shown: 
 
https://adafruit.github.io/arduino-board-index/package_adafruit_index.json,  
 
https://raw.githubusercontent.com/sparkfun/Arduino_Boards/main/IDE_Board_Manager/pack
age_sparkfun_index.json 
 
 

 
Figure 19. Adding board scripts to the Arduino IDE 

 
 
 
 
 
 

http://www.arduino.cc/
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12.3 Adding Libraries 

 
12.3.1 Adafruit Libraries 

 
__ Go to the Libraries tab at Tools>Manage Libraries. Make sure “Type” is set to All and “Topic” 
is set to All, then in the 3rd box type Adafruit. This will search for Adafruit libraries only. 
 
Install the following Adafruit Libraries at a minimum: 
1. Adafruit GFX Library 
2. Adafruit BusIO Library 
3. Adafruit ILI9341 Library 
4. Adafruit ST7735 and ST7789 Library 
5. Adafruit NeoPixel Library 
6. Adafruit TSC2007 Library 
7. Adafruit TouchScreen 
8. Adafruit Zero DMA Library 
9. SdFat - Adafruit Fork 

 
If, during installation the library manager suggests other libraries, go ahead and install those 
too. 

12.3.2 Now in the 3rd box replace Adafruit with SparkFun.  
Install the following Adafruit Libraries at a minimum: 
 
1. (No SparkFun libraries needed for the Display Example software) 
 
 

12.4 Add the Display Demo software to your Arduino folder 
 
The Display Demonstration software is on Github at NovaRadioLabs/Demo-
A_Novaduino_Display . 
 

“Demo-A_NovaduinoDisplayRevC_V1.ino” 
 
The classic Arduino IDE requires the *.ino file to be placed in a folder of the exact same name 
(minus the .ino extension) and then the folder is placed in the Arduino Sketch folder that you 
noted earlier while setting up Preferences. 
 
It looks like this on my computer: 
 

https://github.com/NovaRadioLabs/Demo-A_Novaduino_Display
https://github.com/NovaRadioLabs/Demo-A_Novaduino_Display
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Figure 20. Example of sketch folder 

 
Open the program file by selecting File > Open, then choose the provided Ultrasonic CPA folder. 
See the screenshot above. 
 
 
 
 
 

 
Figure 21. Example of sketch file 

 
Next open the “Demo-A_NovaduinoDisplayRevC_V1.ino” (it may have be a higher Version 
number) by left clicking on it. See the screenshot above. 
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Figure 22. Arduino IDE listing of the Demo-A_Novaduino_Display Software 

 
 
 

The first batch of LCD modules provided to us by 4D Systems contained the ILI9341 graphics 
driver chip while later batches contained the ST7789 driver chip. Please check the driver chip 
specified in the first #define statement (at line 55 here but it may be a different line number in a 
newer version) and change it to either ILI9341 or ST7789 corresponding to the LCD module that 
you have. 

 
Now that the Arduino IDE is all set up with the software provided and libraries it should compile 
properly. Compile the software by clicking on the check mark symbol at the top left of the 
Arduino IDE window. 
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12.5 Load the software onto the Feather Processor 
 

Now make sure that the “enable” switch on the Novaduino® is off then connect your Feather 
Processor (it should already be mounted to the Novaduino® Display board) to your computer via 
a USB cable.  
 
Once that is done, we’ll need to select the board in the “boards manager”.  
 

12.5.1 For Adafruit Feather Processors:  
Go to Tools>Board: Adafruit “SAMD(32 bit…)boards” and in the dropdown menu select 
your Feather Processor type. It might be: “Adafruit Feather M0 Express (SAMD21)” or  
 
 

12.5.2 For SparkFun Thing Plus SAMD51 Processors 
Go to Tools>Board: Sparkfun “SAMD (32 bit ARM…)boards” and in the dropdown menu 
select your Feather Processor type. In this case it is “SparkFun SAMD51 Thing Plus.” 
 

Next, push the enable switch on the Novaduino® to on and then double press the reset button 
located on the Processor board itself. You should hear the computer chime, and a new window 
may pop up. Ignore the new window and go to Tools>Port and select the comm port that shows 
the name of your Feather board next to it. 
 
To verify that the Feather Processor is connected and working properly, go to 
Tools>GetBoardInformation. If all is working, then you should see a small popup window 
showing the name of the board, the USB VID and PID numbers and the serial number of the 
board. Click okay to dismiss this window. 
 
Now we are ready to upload the “Demo_Test-A_NovaduinoDisplayRevC_V1.ino” software to the 
Feather Processor. Left click on the right pointing arrow key icon in the upper left corner of the 
Arduino IDE and wait for the program to upload to the processor. 

 

 
Figure 23. The flash screen shows the file name 
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Once the software is uploaded, the processor will reboot and then the flash screen will be shown for 3 
seconds. (your version may be newer than the one shown here) 
 
 

 
Figure 24. Novaduino®  Display Demonstration Software 

 
The Display Demonstration software is well documented in the .ino file and shows how to: 
 

• Initialize and set up the LCD display 

• Display data to the LCD 

• Initialize and set up the touch screen TSC2007 IC 

• Read and display touch screen data 

• Initialize and set up the RGB LED 

• Send colors to the RGB LED 

• Initialize and set up the micro-SD card reader 

• Read and display data from a micro-SD card 

• Initialize and set up the Keyscan processor 

• Use an interrupt to detect key presses and rotary encoder changes 

• Display data from the Keyscan processor 
 
This provides you with examples of how to get you up-and-running with Novaduino® coding but there is 
so much more that can be done with Novaduino®. Almost any Arduino project that needs a display may 
be adapted to run on Novaduino®.  Please visit our website (novaradiolabs.com) to see additional 
information as it is added. 
  
  

http://www.novaradiolabs.com/
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13.0 3D Printed Case and other Options 
 

13.1 Customizable Faceplate 
The Novaduino® Display KIT001 includes STL and f3d files for full customization of a 3D printed 
Faceplate, allowing you to add your own designs, labels, or logos. You can CNC, laser engrave, 3D-print, 
or apply graphics overlays. The kit also provides two light pipes for Power and RGB LEDs, ensuring a 
professional finish. 

 
 

 
Figure 25. 3D Printed Faceplate Examples 

 
 

 
 

13.2 Front Bezel 
 The Novaduino® Display KIT001 includes an STL file for the Front Bezel for 3D printing. The Front Bezel 
is specifically designed to smoothly integrate the Novaduino® Display and Faceplate with either the 
40mm 3D printed Case, the 120 mm 3D printed Case, or the Hammond 1455N12xx metal case. 
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Figure 26. 3D Printed Front Bezel Examples 

 

13.3 40 mm case w/integrated back panel 
 

The Novaduino® Display KIT-001 includes an STL file for the 40 mm deep case. This Case 
includes mounting posts and vent holes for various sensors or other items. 
 
 

 
Figure 27. 3D Printed 40mm deep Novaduino® Case Examples 
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13.4 120mm case  
 

An STL file for 3D printing your own 120 mm deep case or you may purchase a Hammond 
1455N12xx metal case separately.  The 120 mm deep cases require a separate 3D printed 
Back Cover. 
 

 
Figure 28. Examples of 120 mm long Cases 

 
In the figure above, the middle 120 mm case is 3D printed from an STL file, while the two 
end cases are metal Hammond cases. The Hammond cases feature a removable top for easy 
access to your circuit. 

 
 

13.4.1 Back Cover 
When you purchase an STL file for printing a 120 mm Case or when you purchase a 
Hammond 1455N12xx metal case from us, we provide an STL file for the Back Cover.  
One of the Back Panel designs can accommodate a small 5 Volt Pi-Fan for cooling 
your project if needed. The Back Panel also accommodates the USB-B connector on 
the Prototype Expansion Card.  
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Figure 29. 3D Printed Back Cover examples 

 

13.5 Nav Switch Cap  
The Novaduino® Display KIT001 includes an STL file for 3D printing the Nav Switch Cap.  
 

 
Figure 30. 3D Printed Navigation Switch Caps 

 

13.6 Sensor Cover  
The Novaduino® Display KIT001 includes an STL file for 3D printing the Sensor Cover. This 
holds a 1” x 1” or smaller PCB module onto the back of the 40 mm case. We use it in the 
“Environmental Sensor KIT005” to isolate the temperature/humidity/pressure sensor from 
the heat of internal electronics. 
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Figure 31. 3D Printed Sensor Cover Examples 

 
 

14.0 3D Printed Case Assembly 
 
 

 
Figure 32. 3D Printed Case Assembly 
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15.0 Appendix 
 
 
 
 

16.0 Disclaimers 
 
 
* These are Trademarks for Arduino, Adafruit Industries, Feather, SparkFun Electronics, Thing Plus, ARM 
Cortex, Hammond, 4D Systems , etc… 
 
*Novaduino® is a trademark of Nova Radio Labs LLC 
 
*Novaduino® technology is patent pending 
 
*The Novaduino® Display PCBA and Expansion Proto Card PCBA are Development Boards. They have 
been designed with lead-free components, materials, and PCB processes. They are not yet RoHs 
certified. 
 
The STL and f3d 3D print and design files for Novaduino® are normally sold for a fee and are for your 
personal limited use. If you are interested in the commercial use of these files and designs, please 
contact us.  
 
All programs/code is for example and demonstration only. Nova Radio Labs does not guarantee nor 
warrantee the software. 
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