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1.0 Ultrasonic Sensor Kit 
 
The Novaduino® Ultrasonic Garage Assistant Kit* (UltraGRA) uses a Maxbotix MB1010 ultrasonic sensor, a 
Feather Processor, a Novaduino® Display PCBA along with a 2.4-inch color TFT LCD display module to sense and 
display the distance to your car or any other object and to alert you when it is within a programmable range. It 
can sense distances between 6 inches and beyond 200 inches with a 1-inch resolution*. The sensor is connected 
to the Novaduino® Display via a nice and flexible 6-foot cable.  Mount the sensor a few feet above your garage 
floor to be in line with the front of your car and then mount the Novaduino® Display unit at eye level where you 
can clearly and safely see it from within your car while parking*. Park your car in its ideal location and then 
adjust the max distance on the Ultra Garage Assistant so that the range display turns green and then adjust the 
min distance where the range display background turns red.  Then each time you park your car, keep it within 
the green threshold distance. 
 

 
 

 
We’ve written some open-source software in Arduino-C for the Adafruit Feather M0 processor (included in the 
Kit) that provides a basic display of the range to your car on the Novaduino® Display. We’ve also designed a nice 
case and sensor enclosure that you can print with the included 3D print files. If you don’t have access to a 3D 
printer, you can optionally purchase a 3D printed Case. The kit also comes with a Rotary Encoder and 3 buttons 
for setting the threshold minimum and maximum ranges as well as the brightness of the display backlight. 
 
Note: soldering through hole components is required to assemble this kit. Also, loading downloaded software 
using your own computer is required. Also, 3D printing the case and case components is needed (or you may 
purchase a case). 
 
 
Also, please note that while the final assembled device with its enclosure may appear professional, it is not a certified product. This Ultrasonic Garage  
Assistant Kit is intended solely as a demonstration kit for Novaduino® and for educational purposes only. Users should exercise caution when operating 
this device, particularly during parking maneuvers. Novaduino® assumes no liability for any use or misuse of this educational product. The Ultrasonic 
Garage Assistant Kit is strictly for personal, non-commercial, and instructional use. 
 

2.0 KIT006 Contents 
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Item No. sub elements Product 

KIT006  Novaduino Car Park Assistant (Ultrasonic Sensor) Kit 

  

A01 1 - Novaduino(R)  Display PCBA, NRT1000014 

A02 1 - Display Module, 4DLCD-24320240-RTP-IPS 

A03 1 - LCD Spacer 

A04 Female Headers for PCB  
1- 16 pin and 1 - 12 pin,  2.54 mm pitch (short PTH pins) 

A05 1 - On/Off Switch 

A09 1 - Rotary Encoder 

A10c 1 - Rotary Encoder knob 

A07 3 - Tact Buttons 

A08 3 - key caps for Tact Buttons (White or Black) 

D02 1 - Adafruit Feather M0 Express Processor - ATSAMD21 Cortex M0 

D06 Stacking Header Kit for Feather Processors (long pins) 
1- 16 pin and 1 - 12 pin, female 2.54 mm pitch 

F05 1 - Maxbotix Ultrasonic Rangefinder - LV-EZ1/ Max1010 

F09 1 - 6-foot cable, 4-conductor, black 

F08 
2 - self tapping #2 Sheet Metal Screw, Plain Finish, Flat Head, Phillips 
Drive, 1/4" Length 

F10 1 - BUSHING W/STR RELIEF, NYLON BLACK 

  1 - 6 pin male header, 2.54 mm pitch 

C20 
2 - light pipes for Front Panel 
3mm .188"L 

C16 4 - #6-32 5/8-inch machine screws, Front Panel attach 

C18 4 - E-Z LOK, 6-32 thread 

  1 - cable tie, 4 inches 

    

C30 
STL File Kit for UltraGRA including  Case, Front Bezel, EZ1 Sensor Holder, 
and Faceplate 
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KIT006, Ultrasonic Car Parking Assistant 

 
2.0  General Instructions and Precautions 
  

2.1 Tools and Materials Required:  
 

• Soldering iron with small tip 

• Solder 

• wire cutters 

• wire strippers 

• Philips screwdriver 

• Flat head screwdriver 

• Breadboard 

• small needle nose pliers and/or tweezers 

• small hammer 

• properly grounded ESD mat with wrist strap 
 
It is advisable to perform soldering in a well-ventilated environment or to utilize an air filtration system, such as 
the Hakko FA-400. 
 
A PCB vise may also be very helpful while soldering certain components. 
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2.2 Electrostatic Discharge: 
 
This kit includes Electrostatic Discharge (ESD) sensitive components. Please use a properly grounded ESD mat 
connected to an ESD wrist strap. Please wear the ESD wrist strap when handling or touching the components 
contained in this kit. 
 
Electrostatic discharges can induce very high voltages into these sensitive components that can destroy them or 
cause latent or intermittent damage. 
 

2.3 Soldering: 
 
Soldering of through-hole components to a printed circuit board is required for assembling this kit. Soldering of 
surface mount components is not required.  
 
If you are not familiar with soldering electronics equipment, please watch and follow one of these fine tutorials 
before soldering this kit. Also, we recommend that you practice soldering on something else before attempting 
to solder this kit 
 
Tools | Adafruit Guide To Excellent Soldering | Adafruit Learning System 
 
And/or: 
 
(3129) SparkFun How to Solder with David Stillman - YouTube 
 
Please be careful if you decide to clean any residual flux from the PCB once you are done soldering. We have 
found that cleaning flux from the PCB can possibly contaminate the tact switches and/or the rotary encoder or 
any other switches resulting in intermittent operation. If your switches are acting strange, you may need to 
clean them or replace them. 
 
 

3.0 Discussion of Feather Processor Mounting Options 
 
You can attach the Feather processor to the Novaduino® Display board using several methods. The board comes 
without pre-soldered headers to provide you with greater design flexibility. Female Headers for method 1 are 
included in this Kit. 
 
Methods to mount the Feather Processor to the Novaduino® Display PCB: 

1. Solder female headers (16-pin and 12-pin) onto the Display board and stacking headers on the Feather 
Processor. 

2. Solder the Feather Processor directly to the Display board with 16-pin and 12-pin male headers. 
3. Use a female header on the Display board and male headers on the Feather Processor. 
4. Mount any compatible processor to the Novaduino® Proto Expansion Card (see KIT002), which supports 

display and key interfaces over the backplane. 
5.  

For more details and images, refer to the Novaduino® Display User Manual pdf. This document can be found at  
Products - Nova Radio Labs. 
 

https://learn.adafruit.com/adafruit-guide-excellent-soldering
https://www.youtube.com/watch?v=f95i88OSWB4
https://novaradiolabs.com/products/
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4.0 Assemble the Novaduino® Display PCBA 
 
This section provides directions for Feather attachment method 1. 
 
Step 1. Solder the on/off switch to the Novaduino® Display PCBA. 
 

   
Hold the enable switch in place. We prop the opposite end of the PCBA up to about the same height of the 
on/off switch using a bread board, but you can use anything that is similar in height. Gravity holds the PCB and 
the switch in place. 
 

      
Solder one pin of the on/off switch then make sure that the switch is flush with the PCBIf the switch is not flush 
against the PCB, heat the solder up again while pushing the switch so that it is flush. Next, solder all the other 
pins of the enable switch. 
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Step 2. Solder the 12 pin and 16 pin female stacking headers (with long pins) to the Feather Processor module. 
 
 

 
Insert the stacking header pins from the top side of the Feather processor and solder on the bottom side. 
 
Step 3. Solder the 12 pin and 16 pin female headers with short leads to the Novaduino® PCBA. 
 

  
Use the Feather processor with the long header pins to hold the 16 pin and 12 pin short female headers in place. 
 
 

  
Place the Novaduino® PCBA onto the processor header pins with the front side of the display PCB facing up.  
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Solder one or two pins on each of the headers to hold them in place. Be especially careful to not melt the Flat-PC 
(FPC) connector while soldering near it. 
 
Next, remove the processor from the headers that you are soldering to prevent it from overheating. Then solder 
all the other pins. 
 

 
This picture shows the Feather headers mounted on the back side of the Novaduino® Display PCBA. 
 
 
Step 4. Solder the optional Tact Switches to the Novaduino® Display PCBA.  
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Insert the optional tactile switches into the front side of the Novaduino® Display PCBA, assure they are all the 
way against the PCB. 
 
 

 
Before soldering the tactile switches, assure they are completely flush with the PCB. Double check before 
soldering because once soldered it is very difficult to fix the alignment. This picture shows a switch that was not 
flush with the PCB. We had to cut the switch out and install a new one to fix it. 
 
Solder the switch leads on the back side only. 
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Step 5. Solder the Rotary Encoder to the Novaduino® Display PCBA. 
 

 
Insert the rotary encoder on the front side of the Novaduino® Display and solder on the back side.  
 

5.0 Assemble the LCD and Novaduino® Display PCBA 
 
Before attaching the LCD Display module, please note whether it uses the ILI or ST driver chip. The one shown in 
these pictures uses the ILI driver chip.  
 
Step 6. Attach the Display Module 
 

  
 
Gently open the Flat PC connector with a small flathead screwdriver. Use the screwdriver to alternately push at 
the top and the bottom of the connector. 
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Gently insert the display FPC ribbon into the open FPC connector. Make sure it is all the way in as pictured 
above. 
 
 
 

       
 
Use a small flat head screwdriver to close the top part of the FPC connector, followed by the bottom part. It may 
be necessary to alternate between both sides several times to fully close the connector. Take care not to touch 
the FPC ribbon with the screwdriver. 
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This shows the Flat-PC cable correctly mounted in the FPC connector. 

 
 

       
 
Next slide the LCD Spacer over the LCD as shown. Then snap it into the 3 small holes on the Novaduino® Display 
PCB. 
 
Fold the Display down into the LCD-holder. 
 
If you decide not to install the Novaduino® Display in a case with a faceplate, the LCD Module can be secured to 
the PCBA/LCD-holder by cutting a small piece of the included double-sided adhesive foam and applying it to the 
bottom of the display module and the top of the vertical cross member on the LCD-holder near the tactile 
switches. Typically, this step is unnecessary when using a case, as the faceplate provides adequate support to 
hold the display module in place. 
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Step 7. Attach the Processor Module. 
 
Plug the Feather processor into the 12 and 16 pin headers on the Novaduino® Display as shown below. 
 

 
 
 
 
 

6.0 Print the UltraGA case, EZ1 enclosure, Front Bezel, and Faceplate 
 
Step 8. 3D print or purchase an optional case, Front Bezel, Faceplate, etc… 
 

1. Faceplate  PLA 0.2 mm layer height No Support Needed 
2. Front Bezel  PLA 0.2 mm layer height Some Support Suggested 
3. 40 mm UltraGA Case PLA 0.2 mm layer height No Support Needed 
4. EZ1 Enclosure  PLA 0.2 mm layer height Some Support Suggested 

 
3D-print the STL files provided with KIT006. We use PLA but you may print in other materials. If the size of 
mounting holes and other parts are too small or too large you may need to scale the STL model in your slicer 
software. We have printed each file many times with the layer heights listed above on our Bambu Lab P1S 
printer with good success. You may need to experiment a bit. 
 
We provide the STL, STP and the F3D (Autodesk Fusion model) files for the Faceplate so that you can customize 
it to your liking.  
 
You may also purchase these 3D-printed items from our web store. 
 
Please remember that the final assembled device with a case, although appearing professional, is not a certified 
product that can be re-sold as one.  These 3D-print files are for your own limited and educational use. 
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Novaduino® 3D Printed Case 

 

 
Ultrasonic Sensor Enclosure 
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7.0 Assemble the Ultrasonic Sensor and Cable 
 

 
 
 
 
 
Step 9. Solder the cable to the 6-pin male header 
 
 

      
Using wire strippers carefully strip 1 inch of the outer sheath from the Ultrasonic Sensor cable, be careful to not 
nick the inner wires.  
 
Next, strip ¼ inch of insulation from each of the 4 inner wires, again be careful to not nick the inner conductors. 
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Next, use the soldering iron to “tin” each of the 4 wires with solder.  
 

    
      
Next, plug the 6-pin male header into a bread board to hold it in place and then solder the 4 wires according to 
the picture above and to the following diagram. 
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This picture shows how the header end of the sensor cable will plug into the processor. Do not plug it in yet, that 
will be done during final assembly. 
 
 
 
 
 
 
 



8/26/2025 

Rev 5 Assembly Manual for the 

                      Ultrasonic Garage 
                            Assistant Kit (KIT006)     NOVA RADIO LABS LLC 

 

  

 18 

©2025 Nova Radio Labs LLC 

Step 10. Solder the sensor cable to the Ultrasonic Sensor module. 
 
 

      
Strip and tin the other end of the cable and wires as in step 6. 
 
 
   
 

 
Next, solder the wires to the Ultrasonic Sensor pins from the bottom side up to the top as shown here and 
according to the diagram below. 
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Step 11. Attach the Ultrasonic Sensor to the Sensor Enclosure 
 
 

 
Place the Ultrasonic Sensor into the Sensor Enclosure as shown above. Make sure the holes line up, it only goes 
in one way. 
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Use a small philips screwdrive and attach the Sensor to the Sensor Enclosure using the two #2 screws provided. 
 
 

 
Curle the cable inside the Sensor Enclosure with a service loop as shown and wrap and cinch the provided tie-
wrap around the cable to prevent it from being pulled out. 
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8.0 Assemble the Case 
 
 
Step 12. Insert the EZ-LOKs into the main case 
 
 

 
Press the EZ-Lok-inserts into the main case and then tap until flush with the case using a small hammer. 
 
 

 
Pass the end of the cable with the 6-pin header through the ½ inch hole on the back of the case. 
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9.0 Attach the Processor Module and the sensor cable 
  
Step 13. Attach the Processor Module and the sensor cable. 
 
 
Plug the Feather processor into the 12/16 pin headers on the Novaduino® Display as shown below. 
 

 
 

Next, plug the 6-pin Ultrasonic sensor cable header into the processor header. Make sure that the Vcc pin lines 
up with the red wire and the Gnd pin lines up with the black wire. Fold the wires of the cable towards the 
bottom of the Display PCBA as shown. 
 
 
 
This completes the hardware assembly. Before performing the final assembly with the case, load the software 
and assure that everything works. 
 
 
 

10.0 Load the Software 
 

10.1 Download and Set up the Arduino IDE 
 
Step 14. Load the Arduino IDE to your computer. 
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We use the Legacy Arduino IDE (currently at version 1.8.19) that can be downloaded at www.arduino.cc. 
You may try the web version or the version 2, but we have not tested those with the provided program.  
 
Download and install the Arduino IDE. See arduino.cc/en/software#ide 
 

10.2 Adding Adafruit and SparkFun Board Scripts to the Properties tab 
 
Step15. Add scripts and libraries to the Arduino IDE. 
 
Open the Arduino IDE and go to the preferences under File>Preferences and see the “Settings” tab. 
Note the location of your Sketchbook, you’ll need to know that later. 
We suggest turning-on line numbers. 
In the editable one-line block labeled “Additional Boards Manager URLs:” add the following lines for 
board managers for Adafruit Feather boards and for SparkFun Thing Plus boards, separated by commas 
as shown: 
 
https://adafruit.github.io/arduino-board-index/package_adafruit_index.json,  
 
https://raw.githubusercontent.com/sparkfun/Arduino_Boards/main/IDE_Board_Manager/package_spa
rkfun_index.json 
 
 

 
 
 

10.3 Adding Libraries 

 
10.3.1 Adafruit Libraries 

Go to the Libraries tab at Tools>Manage Libraries. Make sure “Type” is set to All and “Topic” is set to All, 
then in the 3rd box type Adafruit. This will search for Adafruit libraries only. 
 
Install the following Adafruit Libraries at a minimum: 
1. Adafruit GFX Library 
2. Adafruit BusIO Library 
3. Adafruit ILI9341 Library 
4. Adafruit ST7735 and ST7789 Library 
5. Adafruit NeoPixel Library 
6. Adafruit TSC2007 Library 
7. Adafruit TouchScreen 
8. Adafruit Zero DMA Library 

http://www.arduino.cc/
https://www.arduino.cc/en/software/#ide
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9. SdFat - Adafruit Fork 
 

If, during installation the library manager suggests other libraries, go ahead and install those too. 

10.3.2 Now in the 3rd box replace Adafruit with SparkFun.  
Install the following Adafruit Libraries at a minimum: 
 
1. (No SparkFun libraries needed for the UltraGRA) 

 
 
 

10.4 Add the UltraGRA software to your Arduino folder 
 
Step 16. Download the Ultrasonic Garage Assistant software. 
 
The current software is on GitHub at: 
https://github.com/NovaRadioLabs/Novaduino_UltrasonicGarageRangeAssistant 
 

“UltraGRA_Novaduino-Rev1p3.ino” 
 
The classic Arduino IDE requires the *.ino file to be placed in a folder of the exact same name (minus the 
.ino extension) and then the folder is placed in the Arduino Sketch folder that you noted earlier while 
setting up Preferences. 
 
It looks like this on my computer. 
 

 
 
Now open the program file by going to File>Open and select the folder matching the UltraGRA folder 
that you downloaded. See the screenshot above. 
 

 
 

https://github.com/NovaRadioLabs/Novaduino_UltrasonicGarageRangeAssistant
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Next open the UltraGA_Novaduino-Rev1p3.ino that you downloaded (it may have a slightly different 
name depending on the version number) by left-clicking on it. See the screenshot above. 
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The first batch of LCDs provided to us by 4D Systems contained the ILI9341 graphics driver chip while 
later batches contained the ST7735 driver chip. Please edit your copy of the software near line 38 in the 
figure above ( may be a different line number in later versions) to correspond to the display that you 
have in your kit. If you can’t determine the graphics driver chip number don’t worry, go ahead and run 
the software with either one. If the screen looks mixed up, switch to the other graphics driver and it 
should work fine after that. 

 
 
Now that the Arduino IDE is all set up with the software and libraries it should compile properly. Try 
compiling the software by clicking on the check mark in the upper left corner as shown/highlighted 
above. 
 
 

10.5 Load the UltraGRA software onto the Feather Processor 
 

Step 17. Load the Ultrasonic Garage Range Assistant software onto your Feather Processor. 
 
 
Now make sure that the enable switch on the Novaduino® is off and connect your Feather Processor (it 
should already be mounted to the Novaduino® Display board) to your computer via a USB cable. 
(Connect directly to the Feather Processor, not the Novaduino® Display USB-C connector. This connector 
only provides power. It can provide data and power by installing the optional Internal USB-C 
Programming Cable.) 
 
Once that is done, we’ll need to select the correct board in the boards manager.  
 

10.5.1 For Adafruit Feather Processors:  
Go to Tools>Board: Adafruit SAMD (32 bit…) boards and in the dropdown-menu select your 
Feather Processor type. In this case it is “Adafruit Feather M0 Express (SAMD21)” 
 
 

10.5.2 For SparkFun Thing Plus SAMD51 Processors 
Go to Tools>Board: Sparkfun SAMD (32-bit ARM…) boards and in the dropdown menu select 
your Feather Processor type. In this case it is “SparkFun SAMD51 Thing Plus.” 
 

Next, push the enable switch on the Novaduino® Display to “on” and then double press the reset button 
located on the Processor board itself. You should hear the computer chime and a new window may pop 
up. Ignore the new window and go to Tools>Port and select the comm port that shows the name of your 
Feather board next to it. 
 
To verify that the Feather Processor is connected and working properly, go to 
Tools>GetBoardInformation. If all is working, then you should see a small popup window showing the 
name of the board, the USB VID and PID numbers and the serial number of the board. Click okay to 
dismiss this window. 
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Now we are ready to upload the UltraGRA software to the Feather Processor. Left click on the right 
pointing arrow key icon in the upper left corner of the Arduino IDE and wait for the program to upload 
to the processor. 
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Once the software is uploaded, the processor will reboot and then the flash screen will be shown for 3 seconds. 
(your version may be newer than the one shown here) 
 

 
When the software is properly loaded your screen should look similar to this except the range will indicate 000 
inches since the ultrasonic sensor is not connected yet. 
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11.0 Final Assembly 
         
Step 18. Final Assembly 
 
 
  

 
 
Place the strain relief bushing around the sensor cable leaving about 5 inches of cable for a service loop inside 
the case. Press the bushing/cable into the mounting hole until it snaps in. 
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If you have purchased an optional 3.7 volt Lithium Ion Polymer battery with a 2-pin 2.0 mm JST connector, 
attach it directly to the Feather processor.  
 
Warning: We suggest only purchasing batteries from stores that also carry the Feather or Feather compatible 
processors such as Adafruit.com or SparkFun.com. We have found that batteries purchased on Amazon for 
example have the wrong polarity and if used, they will destroy your Feather processor. 
 
 

 
 
Cut a small piece of double-sided foam pad, provided, and attach it to the battery. 
Attach the battery to the bottom inside of the case. 

 

After the battery has been attached and the sensor cable attached to the Feather processor, place the 
Novaduino™ PCBA into the front bezel making sure that the holes for the usb-c connector and the microSD card 
holder line up properly. 
 
Attach the light pipes to the front panel. Depending on the accuracy of your 3D printer the light pipes may fit 
snugly into the 2 – 3 mm holes. If the holes are too tight, you can drill them out with a 3 mm drill bit or 1/8-inch 
drill bit. If the light pipes are too loose to reliably stay secure, you may glue them in. We used super glue in the 
picture below. 
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Next, Remove the screen protector and place the front panel onto the front bezel and over the buttons.  
Lastly, Screw the assembly together with the 4 provided #6-32 machine screws. 
 

12.0 How to set up and Use 
 
Securely mount the Novaduino® UltraGA display unit in a location that is easy to see from within your car while 
parking. We use Velcro tape on both the display unit and the mounting surface so that it can easily be removed. 
Plug a USB-C power cable into the display unit for continuous power. 
 
Mount the Ultrasonic sensor enclosure to a piece of wood or to a wall using 2 #6 self-tapping screws inserted 
through the mounting holes on the enclosure. Or tape or attach the sensor enclosure to a chip-clip. Now mount 
or attach the sensor assembly to a cabinet or shelf or wall in front of your car.  
The sensor has a wide field of view, so when mounting in front of your car make sure there are no other objects 
in front of, and to the side of the sensor for several feet. Please see the Maxbotics MB1010 Data Sheet for 
further information on this sensor: MB1010 LV-MaxSonar-EZ1 – MaxBotix. 
 
Park your car in your desired position, then adjust settings as follows: 
 

Max Range – use button number 5, the bottom button to adjust the maximum range at which the range 
display digits turn green. Momentarily press button-5 and the max range in inches will be displayed and 
the color RGB LED will stop flashing. Adjust the max range with the rotary encoder knob. Once the max 
range is adjusted, press the rotary encoder knob to enter it.  
 
Min Range – use button number 4, the 2nd button from the bottom, to adjust the minimum range at 
which the range display background turns red. Momentarily press button-4 and the min range in inches 
will be displayed and the color RGB LED will stop flashing. Adjust the min range with the rotary encoder 
knob. Once the min range is adjusted, press the rotary encoder knob to enter it. 
 
Brightness – Press button number 3, the 3rd button from the bottom, to adjust the TFT LCD backlight 
brightness. Adjust the brightness with the rotary encoder knob, once adjusted, press the rotary encoder 
knob to complete your entry. 

 
Once an adjustment is entered the RGB LED will start to flash, and the Ultrasonic sensor will start to update 
again. 
 

https://maxbotix.com/products/mb1010
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This image displays the Novaduino® Ultrasonic Garage Assistant with its sensor attached, detecting an object at 
a distance of 68 inches. Since the range exceeds the maximum range, the numbers remain white and the RGB 
LED flashes blue. 
 

 

 
When the range to the object is between the maximum and minimum range, the numbers turn green and the 
RGB LED flashes green. 
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When the object is less than the minimum range it is too close, and the number background turns red while the 
RGB LED flashes red. 

 
 

13.0 Going Further 
 
The Ultrasonic Garage Assistant Kit is just one application of the wider Novaduino® Display and Microcontroller 
prototyping platform. You can customize the faceplate, modify the open-source software, add other sensors or 
devices, add Wi-Fi or Bluetooth or LoRa, and even add additional circuitry to make almost anything that you 
want.  
 
Here are just a few ideas to enhance your Ultrasonic Garage Assistant: 
Add a Carbon Monoxide sensor and a buzzer to alert you when dangerous levels of CO gas are detected.  
Substitute the Feather processor with a Wi-Fi capable Feather processor and send an alert to your phone when a 
car arrives or when the CO level is too high. 
Add a temperature sensor to make the range measurement more accurate and display the temperature. 
Add a light sensor to detect when the garage door is open during the day or when the light is left on at night. 
Add a real time clock module and display the time or log the range over time to a microSD card. 
 
Range accuracy will depend on several environmental factors including temperature, humidity, dust in the air, 
etc. You can go further by adding sensors and software to more accurately calibrate the ultrasonic sensor. We 
do not guarantee the accuracy of the Maxbotix MB1010 sensor nor the Arduino pulse width measuring 
algorithm. 
 
Please see the Novaduino® User’s Manual, Novaduino® Display Schematic and the Novaduino® Display Assembly 

Guide available at Products - Nova Radio Labs.  Also see the Novaduino® Prototype Expansion Card resources 
at the same website.  
 
 
 
 

https://novaradiolabs.com/products/
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14.0 Appendix 
 
Feather processors support Arduino, microPython, CircuitPython*, or other languages supported by the 
processor manufacturer. Processors that may be used with the Novaduino® Display PCBA include: 
 

Processor Supplier Part number Processor/Clock 
speed 

note 

Feather M0 Adafruit 2772 or 3403 Cortex®M0/48 MHz stocked by Nova Radio 
Labs 

Thing Plus SAMD51 SparkFun DEV-14713 Cortex®M4+/120 
MHz 

stocked by Nova Radio 
Labs 

Feather M0 WiFi Adafruit 3044 Cortex®M0/48 MHz 
Supports: 2.4 GHz 
Wi-Fi 

stocked by Nova Radio 
Labs 

Feather M4 Adafruit 3805 Cortex®M4+/120 
MHz 

stocked by Nova Radio 
Labs 

Feather RP2040 Adafruit 4884  Still in test, but should 
work with Novaduino™ 

Thing Plus RP2040 SparkFun DEV-17745 two Cortex®-M0+/ 
up to 133MHz 
 

Still in test, but should 
work with Novaduino™ 

Thing Plus STM32 SparkFun DEV-17712 Cortex®-M4/up to 
168 MHz 

Still in test, but should 
work with Novaduino™ 

Thing Plus - ESP32-
S2 WROOM 

SparkFun  LX7/up to 240 MHz 
Supports: 2.4 GHz 
Wi-Fi 

Still in test, but should 
work with Novaduino™ 

Thing Plus ESP32-C6 DEV-22924 WRL-15663 RISC-V/up to 160 
MHz 
Supports: 2.4 GHz 
WiFi 6, 
Bluetooth® 5.3, 
Zigbee and Thread 
(802.15.4), 

Still in test, but should 
work with Novaduino™ 

Most any Feather form factor processor that has the Feather pinout should work. See the Novaduino Users Guide for technical details. 
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Assembled Novaduino® Display top side 

 
 

 
Assembled Novaduino® Display bottom side 
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*Please note that while the final assembled device with its enclosure may appear professional, it is not a 
certified product. This Ultrasonic Garage Assistant Kit is intended solely as a demonstration kit for Novaduino® 
and for educational purposes only. Users should exercise caution when operating this device, particularly during 
parking maneuvers. Novaduino® assumes no liability for any use or misuse of this educational product. The 
Ultrasonic Garage Assistant Kit is strictly for personal, non-commercial, and instructional use. 
 
*Range accuracy will depend on several environmental factors including temperature, humidity, dust in the air, 
etc... You can go further by adding sensors to more accurately calibrate the ultrasonic sensor. We do not 
guarantee the accuracy of the Maxbotix MB1010 sensor nor the Arduino pulse width measuring algorithm. 
 
*The 3D print files for the Novaduino® Ultrasonic Car Parking Assistant Kit includes STL files for the Front Bezel, 
the 40 mm UltraGRA Case, the MB1010 Sensor Enclosure, and the Faceplate/Front Panel with 3 buttons and 
rotary encoder. These files as well as additional files may be sold for a small fee and are for your limited personal 
use only. The 3D print file kit also includes the Faceplate STL, STP and F3D files so that you can customize the 
front panel however you like. 
 
* These are Trademarks for Arduino, Adafruit Industries, Feather, SparkFun Electronics, Thing Plus, ARM Cortex, 
Hammond, 4D Systems, etc… 
 
*Novaduino® is a registered trademark of Nova Radio Labs LLC 
 
*The Novaduino® Display PCBA and Expansion Proto Card PCBA are Development Boards. They have been 
designed with lead-free components, materials, and PCB processes. They are not yet RoHS, UL, FCC, nor CE 
certified. 
 
 


