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1.0 Environment Sensor Kit005 
 

 
 
Keep track of your surroundings using this advanced sensor kit, perfect for creating smart home setups 
or DIY weather stations. Instantly view the carbon dioxide levels in your room along with various Volatile 
Organic Compounds (VOCs), such as ethanol, toluene, hydrogen, and other oxidizing gases. These 
readings are combined to give you an Air Quality Index (AQI) indicator ranging from 1 to 5 where 1 is 
“Best” and 5 “Worst”. The kit also measures temperature, humidity, and barometric pressure, displaying 
all results on the Novaduino® 2.4” touchscreen color display powered by open-source software on an 
Arduino-compatible Feather* processor. Because the system is open source, you can add more sensors 
and personalize the display. The kit comes with high-accuracy* sensors and offers optional 3D-
printed enclosures for a sleek look. 
 
With provided assembly instructions and free Arduino software, getting started is straightforward. 
 
You'll need to download Arduino C code from GitHub and do some soldering and mechanical 
assembly. You’ll also need to do 3D printing of the Case and other items or alternatively you 
can purchase a 3D printed Case on our website. 
 
 
 
 
*This developmental hardware and software are provided as uncalibrated and are not intended for use in critical 
applications. The Environmental Sensor is not designed for safety-related, medical, or end-product purposes. It is 
offered solely for educational and experimental use, with no warranty or guarantee for any other application. 
The AQI, VOC, and eCO2 sensors require at least 48 hours of burn in before values are stable. 
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Kit005 Includes: 
 

 Novaduino™ Display Kit001 

 Bosch BME280 Sensor and Qwiic cable. (Temperature, Humidity, and Barometric Pressure) 

 ScioSense ENS160 Sensor and Qwiic cable. (Air Quality Index (AQI), estimated eCO2, Volatile 
Organic Compounds (VOC)) 

 Rotary Encoder and 3 Buttons and  

Options: 
 

 Internal USB Programming Cable Kit 

 Connects the external usb-c connector to the Feather usb-b micro connector so you can 
re-program the Feather without disassembling the case. 

 3D Printed Case Kit 

 Includes 40mm vented case, front Bezel, Front Panel (w/ all holes), sensor cover, and 4 
screws 

 
 
2.0 KIT005 Contents 
 

Item 
No. 

sub 
elements Quant Product 

KIT005     Novaduino Environment Sensor Kit 

KIT001 

A01 1 Novaduino(tm) Display PCBA 

A02 1 Display Module 

A03 1 LCD Spacer 

A04 2 
Headers for Feather Proc 
16 pin and 12 pin, female 2.54 mm pitch 

A05 1 On/Off Switch 

 
C20 2 

light pipes for Front Panel 
3MM PMLP FLAT REVMT WC .188"L 

 A09 1  Rotary Encoder 

 A10 1 Rotary Encoder knob 
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  3 Tact Switch 

  3 Cap for Tact Switch 

 D02 1 Adafruit Feather M0 Express - ATSAMD21 Cortex M0 

  2 Stacking Headers for Feather Processor 

 
F02 1 

BME280: Temp.,Humidity, Pressure Sensor w/ Qwiic 
connectors  

 F08 6 self-tapping screw #2 Thread Size, 1/4" Length 

 
F03 1 

ENS160: TVOC, eCO2 and AQI Sensor, w/ Qwiic 
connectors 

 H03 2 Qwiic to Qwiic, Flexible, 100 mm 

 
C16 4 #6-32 5/8-inch machine screws, Front Panel attach 

 C18 4 E-Z LOK, 6-32 thread 

 C19 1 Double Sided Sticky Pads, white 2mm thick 

 C30 1 STL File Kit 
 
 
 

 
 
 
 
 



11/10/2025 
Rev2 Assembly Manual for the  

Novaduino® Environmental Sensor Kit (Kit005)  NOVA RADIO LABS LLC 
 
 

  
 6 

©2025 Nova Radio Labs LLC 

3.0  General Instructions and Precautions 
 
3.1 Tools and Materials Required:  
 

 Soldering iron with small tip 
 Solder 
 wire cutters 
 wire strippers 
 Philips screwdriver 
 Flat head screwdriver 
 Breadboard 
 small needle nose pliers and/or tweezers 
 small hammer 
 properly grounded ESD mat with wrist strap 

 
It is advisable to perform soldering in a well-ventilated environment or to utilize an air filtration system, 
such as the Hakko FA-400. 
 
A PCB vise may also be very helpful while soldering certain components. 
 
 
 
3.2 Electrostatic Discharge: 
 
This kit includes Electrostatic Discharge (ESD) sensitive components. Please use a properly grounded ESD 
mat connected to an ESD wrist strap. Please wear the ESD wrist strap when handling or touching the 
components contained in this kit. 
 
Electrostatic discharges can induce very high voltages into these sensitive components that can destroy 
them or cause latent or intermittent damage. 
 
3.3 Soldering: 
 
Soldering of through-hole components to a printed circuit board is required for assembling this kit.  
-- Soldering of surface mount components is not required.  
 
If you are not familiar with soldering electronics equipment, please watch and follow one of these fine 
tutorials before soldering this kit. Also, we recommend that you practice soldering on something else 
before attempting to solder this kit 
 
Tools | Adafruit Guide To Excellent Soldering | Adafruit Learning System 
 
And/or: 
 
(3129) SparkFun How to Solder with David Stillman - YouTube 
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Please be careful if you decide to clean any residual flux from the PCB once you are done soldering. We 
have found that cleaning flux from the PCB can possibly contaminate the tact switches and/or the rotary 
encoder or any other switches resulting in intermittent operation. If your switches are acting strange, 
you may need to clean them or replace them. 
 
 
4.0 Discussion of Feather Processor Mounting Options 
 
You can attach the Feather processor to the Novaduino® Display board using several methods. The 
board comes without pre-soldered headers to provide you with greater design flexibility. Female 
Headers for method 1 are included in this Kit. 
 
Methods to mount the Feather Processor to the Novaduino® Display PCB: 

1. Solder female headers (16-pin and 12-pin) onto the Display board and stacking headers on the 
Feather Processor. 

2. Solder the Feather Processor directly to the Display board with 16-pin and 12-pin male headers. 
3. Use a female header on the Display board and male headers on the Feather Processor. 
4. Mount any compatible processor to the Novaduino® Proto Expansion Card (see KIT002), which 

supports display and key interfaces over the backplane. 
5.  

For more details and images, refer to the Novaduino® Display User Manual pdf. This document can be 
found at  Products - Nova Radio Labs. 
 
 
5.0 Assemble the Novaduino® Display PCBA 
 
This section provides directions for Feather attachment method 1. 
 
Step 1. Solder the on/off switch to the Novaduino® Display PCBA. 
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Hold the enable switch in place. We prop the opposite end of the PCBA up to about the same height of 
the on/off switch using a bread board, but you can use anything that is similar in height. Gravity holds 
the PCB and the switch in place. 
 

   
 

    
Solder one pin of the on/off switch then make sure that the switch is flush with the PCB. If the switch is 
not flush against the PCB, heat the solder up again while pushing the switch so that it is flush. Next, 
solder all the other pins of the enable switch. 
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Step 2. Solder the 12 pin and 16 pin female stacking headers (with long pins) to the Feather Processor 
module. 
 
 

 
Insert the stacking header pins from the top side of the Feather processor and solder on the bottom 
side. 
 
Step 3. Solder the 12 pin and 16 pin female headers with short leads to the Novaduino® PCBA. 
 

  
Use the Feather processor with the long header pins to hold the 16 pin and 12 pin short female headers 
in place. 
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Place the Novaduino® PCBA onto the processor header pins with the front side of the Display PCB facing 
up.  
 

  
Solder one or two pins on each of the headers to hold them in place. Be especially careful to not melt 
the Flat-PC (FPC) connector while soldering near it. 
 
Next, remove the processor from the headers that you are soldering to prevent it from overheating, 
then solder all the other pins. 
 

 
This picture shows the Feather headers mounted on the back side of the Novaduino® Display PCBA. 
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Step 4. Solder the optional Tact Switches to the Novaduino® Display PCBA.  
 

  
Insert the tactile switches into the front side of the Novaduino® Display PCBA, assure they are all the 
way against the PCB. 
 
 

 
Before soldering the tactile switches, assure they are completely flush with the PCB. Double check 
before soldering because once soldered it is very difficult to fix the alignment. This picture shows a 
switch that was not flush with the PCB. We had to cut the switch out and install a new one to fix it. 
 
Solder the switch leads on the back side only. 
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Step 5. Solder the Rotary Encoder to the Novaduino® Display PCBA. 
 

 
Insert the rotary encoder on the front side of the Novaduino® Display and solder on the back side.  
 
 
6.0 Assemble the LCD and Novaduino® Display PCBA 
 
Before attaching the LCD Display module, please note whether it uses the ILI or ST driver chip. The one 
shown in these pictures uses the ILI driver chip.  
 
Step 6. Attach the Display Module 
 

  
 
Gently open the Flat PC connector with a small flathead screwdriver. Use the screwdriver to alternately 
push at the top and the bottom of the connector. 
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Gently insert the display FPC ribbon into the open FPC connector. Make sure it is all the way in as 
pictured above. 
 

  
 
Use a small flat head screwdriver to close the top part of the FPC connector, followed by the bottom 
part. It may be necessary to alternate between both sides several times to fully close the connector. 
Take care not to touch the FPC ribbon with the screwdriver. 
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This shows the Flat-PC cable correctly mounted in the FPC connector. 
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Next slide the LCD Spacer over the LCD as shown. Then snap it into the 3 small holes on the Novaduino® 
Display PCB. 
 
Fold the Display down into the LCD-holder. 
 
If you decide not to install the Novaduino® Display in a case with a faceplate, the LCD Module can be 
secured to the PCBA/LCD-holder by cutting a small piece of the included double-sided adhesive foam 
and applying it to the bottom of the display module and the top of the vertical cross member on the 
LCD-holder near the tactile switches. Typically, this step is unnecessary when using a case, as the 
faceplate provides adequate support to hold the display module in place. 
 
 
 
Step 7. Attach the Processor Module. 
 
Plug the Feather processor into the 12 and 16 pin headers on the Novaduino® Display as shown below. 
 

 
 
 
 
7.0 Print the 40 mm Display case, Sensor enclosure, Front Bezel, and Faceplate 
 
Step 8. 3D print or purchase an optional Case, Front Bezel, Faceplate, and Sensor Enclosure. 
 

1. Faceplate  PLA 0.2 mm layer height No Support Needed 
2. Front Bezel  PLA 0.2 mm layer height Some Support Suggested 
3. 40 mm UltraGA Case PLA 0.2 mm layer height No Support Needed 
4. Sensor Enclosure PLA 0.2 mm layer height Some Support Suggested 
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3D-print the STL files provided with KIT005. We use PLA but you may print in other materials. If the size 
of mounting holes and other parts are too small or too large you may need to scale the STL model in 
your slicer software. We have printed each file many times with the layer heights listed above on our 
Bambu Lab P1S printer with good success. You may need to experiment a bit. 
 
We provide STL, STP and F3D (Autodesk Fusion model) files for the Faceplate so that you can customize 
it to your liking.  
 
You may also purchase these 3D-printed items from our web store. 
 
Please remember that the final assembled device with a case, although appearing professional, is not a 
certified product that can be re-sold as one.  These 3D-print files are for your own limited and 
educational use.  Also please note that this sensor is not for any safety, medical or finished product 
usage. We're selling it for hobby education & experimentation and don't guarantee it for any 
other purpose! 

 
Novaduino® 3D Printed Case 
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Temp/Humidity/Pressure Sensor Enclosure 
 

 
 
8.0 Assemble the Sensors and Cables 
 
Step 9. Attache the ENS160 and the BME280 sensors to the Novaduino® circuit card using the two 
100mm Qwiic cables in preparation for testing in a later step. 
   

 
            This shows both the BME280 sensor and the ENS160 sensor connected to the Novaduino® Display 
PCBA. This example uses the Adafruit Feather RP2040 processor with the optional USB internal jumber 
cable.  
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9.0 Load the Software 
 
Step 10. Install the Arduino IDE and load the software. 
 
 
9.1 Download and Set up the Arduino IDE 

We use the Classic Arduino IDE that can be downloaded at www.arduino.cc. You may try the 
web version or the version 2, but we have not tested those with the provided program.  
Download and install the Arduino IDE. 
 

9.2 Adding Adafruit and SparkFun Board Scripts to the Properties tab 
 
Open the Arduino IDE and go to the preferences under File>Preferences and see the “Settings” 
tab. 
Note the location of your Sketchbook, you’ll need to know that later. 
We suggest turning-on line numbers. 
In the editable one-line block labeled “Additional Boards Manager URLs:” add the following lines 
for board managers for Adafruit Feather boards and for SparkFun Thing Plus boards, separated 
by commas as shown: 
 
https://adafruit.github.io/arduino-board-index/package_adafruit_index.json,  
 
https://raw.githubusercontent.com/sparkfun/Arduino_Boards/main/IDE_Board_Manager/pack
age_sparkfun_index.json 
 
 

 
 
 

9.3 Adding Libraries 
 

9.3.1 Adafruit Libraries 



11/10/2025 
Rev2 Assembly Manual for the  

Novaduino® Environmental Sensor Kit (Kit005)  NOVA RADIO LABS LLC 
 
 

  
 19 

©2025 Nova Radio Labs LLC 

Go to the Libraries tab at Tools>Manage Libraries. Make sure “Type” is set to All and “Topic” is 
set to All, then in the 3rd box (search box) type Adafruit. This will search for Adafruit libraries 
only. 
 
Install the following Adafruit Libraries at a minimum: 
1. Adafruit GFX Library 
2. Adafruit BusIO Library 
3. Adafruit ILI9341 Library 
4. Adafruit ST7735 and ST7789 Library 
5. Adafruit NeoPixel Library 
6. Adafruit TSC2007 Library 
7. Adafruit TouchScreen 
8. Adafruit Zero DMA Library 
9. SdFat - Adafruit Fork 

 
If, during installation the library manager suggests other libraries, go ahead and install those 
too. 
 

9.3.2 SparkFun Libraries 
 Now in the 3rd box (search box) replace Adafruit with SparkFun.  

Install the following SparkFun Libraries at a minimum: 
 
1. SparkFun BME280 Library 
2. SparkFun ENS160 Libarary 

 
 

9.4 Add the Environmental Sensor software to your Arduino folder 
 
The current software is on Github at:  
 
https://github.com/NovaRadioLabs/Novaduino_Environment_Sensors/tree/main 
 

“Novaduino_EnvSensors-RevXXX.ino” 
 
The name may be slightly different. 
 
The classic Arduino IDE requires the *.ino file to be placed in a folder of the exact same name 
(minus the .ino extension) and then the folder is placed in the Arduino Sketch folder that you 
noted earlier while setting up Preferences. 
 
It looks like this on my computer. 
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Now open the program file by going to File>Open and select the folder matching the EnvSensors 
folder that you were provided with. See the screenshot above. 
 

 
 
 
Next open the Novaduino_EnvSensors-RevXXX.ino software by left clicking on it. See the 
screenshot above. 
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Note: the first batch of LCDs provided to us by 4D Systems contained the ILI9341 graphics driver 
chip while later batches contained the ST7735 driver chip. The ILI or ST in the software name as 
shown above Must correspond to the LCD Display that was provided to you. Your display model 
number should be indicated on your packing slip paperwork. Change the code right after the 
“#define” directive shown highlighted above at line 51 to match your display. 
 
 

 
 
Now that the Arduino IDE is all set up with the software and libraries it should compile properly. 
Try compiling the software by clicking on the check mark as shown above. 
 
 

9.5 Load the Environmental Sensor   .ino software onto the Feather Processor 
 

Make sure that the enable switch on the Novaduino® is off and connect your Feather Processor 
(it should already be mounted to the Novaduino® Display board) to your computer via a USB 
cable.  
 
Once that is done, we’ll need to select the board.  
 

9.5.1 For Adafruit Feather SAMD Processors:  
Go to Tools>Board: Adafruit SAMD(32 bit…)boards and in the dropdown menu select 
your Feather Processor type. In this case it is “Adafruit Feather M0 Express (SAMD21)” 
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Also change lines 69 to 71 to match the code below if it does not already match: 
 

 
 

9.5.2 For SparkFun Thing Plus SAMD51 Processors 
Go to Tools>Board: Sparkfun SAMD (32 bit ARM…) boards and in the dropdown menu 
select your Feather Processor type. In this case it is “SparkFun SAMD51 Thing Plus.” 
 
Also change lines 69 to 71 to match the code below if it does not already match: 
 

 
 
 

9.5.3 For Adafruit Feather RP2040 Processors:  
Go to Tools>Board: Raspberry Pi RP2040 boards and in the dropdown menu select your 
Feather Processor type. In this case it is “Adafruit FeatherRP2040” 
 
Also change lines 69 to 71 to match the code below if it does not already match: 
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Next, push the enable switch on the Novaduino® to “on” and then double press the reset button 
located on the Processor board itself. You should hear the computer chime and a new window 
may pop up. Ignore the new window and go to Tools>Port and select the comm port that shows 
the name of your Feather board next to it. 
 
To verify that the Feather Processor is connected and working properly, go to 
Tools>GetBoardInformation. If all is working, then you should see a small popup window 
showing the name of the board, the USB VID and PID numbers and the serial number of the 
board. Click okay to dismiss this window. 
 
Now we are ready to upload the Novaduino® Environmental Sensor ino software to the Feather 
Processor. Left click on the right pointing arrow key icon in the upper left corner of the Arduino 
IDE and wait for the program to upload to the processor. 
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Once the software is uploaded, the processor will reboot and then the flash screen will be shown for 3 
seconds. (your version may be newer than the one shown here) 
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The Novaduino® Environmental Sensor with the software loaded and the sensors connected. This 
Novaduino® Display PCBA has all the optional tactile switches and the optional Navigation switch 
installed. 
 
 

9.6 Adjust Altitude for Barometric Pressure Reading 
 
To display Barometric Pressure at equivalent sea level, you need to adjust MYALTITUDE in the software 
to match your actual altitude above sea level (in feet). This can be found on the internet by doing a 
search for “what is my elevation.” We have used whatismyelevation.com to successfully determine out 
altitude at 4005 feet which is why the MYALTITUDE is set to this.  
 
You can also set MYALTITUDE to 0.0 to determine the actual Barometric Pressure at your location. 
Weather stations, however, typically provide equivalent sea level Barometric readings. 
 
We plan to add the ability to set the MYALTITUDE variable via the rotary encoder in a future release of 
the software. 
 
You should probably also calibrate your barometer reading. We have provided a PRCAL variable for this 
purpose, but it is not guaranteed to be the best method of calibration as it is only a linear calibration. 
Actual calibration may not be linear, we have not determined this, so it is up to you to determine. 
 
Please do not use this Barometer for any critical applications, we do not guarantee its accuracy. 
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10.0 Final Assembly 
 

10.1 Assemble the Case 
 
Step 11. Insert the EZ-LOKs into the main case 
 

 
Press the EZ-Lok-inserts into the main case as shown with the open slot down, and then tap until flush 
with the case using a small hammer.  
 
Step 12. Mount the Sensors to the Case 
 

  
 Mount the ENS160 sensor as shown here with the 2 Qwiic cables attached. 
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Trace an outline of the Sensor Enclosure on a piece of cardboard as shown here. 
 

   
Cut along the traces on the cardboard to make an insulating gasket for the BME280 sensor. 
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Also poke holes for the screws and cut a wide slit for the Qwiic connector as shown here. 
   
 

      
1st attach the Qwiic cable to the BME280 sensor and then attach the BME280 sensor to the Sensor 
Enclosure with 3 of the ¼” #2 self-tapping screws. Next pass the Qwiic connector through the cardboard 
insulator and the small rectangular hole in the case as shown here. 
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Attach the Sensor Enclosure to the Case with 2 of the ¼” #2 self-tapping screws as shown here. 
 
   

 
Plug the Qwiic cable from the BME280 into the ENS160 Qwiic jack as shown here. 
 
 



11/10/2025 
Rev2 Assembly Manual for the  

Novaduino® Environmental Sensor Kit (Kit005)  NOVA RADIO LABS LLC 
 
 

  
 30 

©2025 Nova Radio Labs LLC 

  
Optional: if you have purchased a Lithium Ion battery, attach it as shown here using the double sided 
sticky pad. 
 

 
Plug the Qwiic cable into the Novaduino PCBA as shown here. Also plug the optional battery into the 
Feather. 
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Assembly overview 
 
 

        
Mount the Novaduino PCBA into the Front Bezel as shown here and assemble with the case. 
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Remove the screen protector. 
 
 

 
Attache the light pipes to the Faceplate. We suggest using a little bit of glue to hold them in. 
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The finished Novaduino Environmental Sensor Kit.  
 
11.0 Software Adjustments and Customization 
 
The open-source code for the Novaduino® Environmental Sensor Kit has several adjustments and 
customizations that may be made with very little effort.  
 
Please save the code to a new file name so that no one will confuse it with the code that you 
downloaded from our GitHub site and so that you can easily go back to that code if needed. 
 
 Locations where you can easily make changes are marked like this:  ---------HERE---------. 
 
Please re-compile the code to make sure you have not made any errors before loading it onto your 
processor.  
 
 

11.1 Adjust the top banner text:  
Personalize your device by putting your name or anything else in the top banner text. 
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11.2 Add more colors to the color map:  

 
You can define more colors for the Color Map. Both ST7789 and ILI9341 color displays that we use in the 
Novaduino® Display use the same RGB565 serial word format for color. That’s 5bits Red/6 bits Green/5 
bits Blue expressed in a 4 digit Hexadecimal number as in the code below. Search online for “RGB565 
color picker.” We have used: RGB565 Color Picker - Barth Development successfully for this purpose. 
 
We created a Color Map so that the code works with either display driver, otherwise we would need to 
switch between colors such as ST77XX_WHITE or ILI9341_BLUE for example whenever a different 
display driver chip is used.  
 

 
 
 
 

11.3 Adjust the color scheme:  
 
You may experiment with the background color, text colors, top banner colors etc… using the definitions 
shown below. The ALTTEXT definition is not currently used and is for future use when we add code to 
adjust various values using the keys and/or the rotary encoder. You can use the colors from the Color 
Map, or you could use colors from the display drivers such as ST77XX_WHITE or ILI9341_BLUE for 
example.  
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11.4 Adjust Your Elevation: 

 
We have already discussed this earlier, but you can adjust your elevation using the MYALTITUDE 
definition. This will make the Barometric Pressure readout show your equivalent sea level pressure 
which is what weather stations normally provide. We have had success using the website: 
www.whatismyelevation.com. Also, adjust this to 0 if you would like to display the true pressure where 
you are. 
 

 
 
 
 

11.5 Adjust Temperature, Humidity, and Pressure Calibration: 
 
See the code snippet above. These calibration values are simply added to the Temperature or Humidity 
or Pressure measurements and may not be sufficient to calibrate these values at all the conditions that 
you may encounter.  
 
You may want to come up with your own calibration algorithms if you need better accuracy. Or you can 
also change the sensors for more accurate sensing if you desire. You can even add our “Prototype 
Expansion Card” to add additional circuitry for larger sensors or more signal conditioning.  
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12.0 Appendix 
 
Feather Processors support Arduino programming, microPython, CircuitPython*, or other languages 
supported by the processor manufacturer. Processors that may be used with the Novaduino® Display 
PCBA include: 
 

Processor Supplier Part number Processor/Clock 
speed 

note 

Feather M0 Adafruit 2772 or 3403 Cortex®M0/48 MHz stocked by Nova Radio 
Labs 

Thing Plus SAMD51 SparkFun DEV-14713 Cortex®M4+/120 
MHz 

stocked by Nova Radio 
Labs 

Feather M0 WiFi Adafruit 3044 Cortex®M0/48 MHz 
Supports: 2.4 GHz 
Wi-Fi 

stocked by Nova Radio 
Labs 

Feather M4 Adafruit 3805 Cortex®M4+/120 
MHz 

stocked by Nova Radio 
Labs 

Feather RP2040 Adafruit 4884  Works with Novaduino, 
soon to be stocked by 
Nova Radio Labs 

Thing Plus RP2040 SparkFun DEV-17745 two Cortex®-M0+/ 
up to 133MHz 
 

Still in test, but should 
work with Novaduino™ 

Thing Plus STM32 SparkFun DEV-17712 Cortex®-M4/up to 
168 MHz 

Still in test, but should 
work with Novaduino™ 

Thing Plus - ESP32-
S2 WROOM 

SparkFun  LX7/up to 240 MHz 
Supports: 2.4 GHz 
Wi-Fi 

Still in test, but should 
work with Novaduino™ 

Thing Plus ESP32-C6 DEV-22924 WRL-15663 RISC-V/up to 160 
MHz 
Supports: 2.4 GHz 
WiFi 6, 
Bluetooth® 5.3, 
Zigbee and Thread 
(802.15.4), 

Still in test, but should 
work with Novaduino™ 

Most any Feather form factor processor that has the Feather pinout should work. See the Novaduino Users Guide for technical details. 

Raspberri Pi    Many versions can be 
mounted to the 
Novaduino™ Proto 
Expansion Card and drive 
the Display and controls 
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Assembled Novaduino® Display top side 

 
 

 
Assembled Novaduino® Display bottom side 
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13.0 Notes and Disclaimers 
 
*Please note that while the final assembled device with its enclosure may appear professional, it is not a 
certified product. This Environmental Sensor Kit is intended solely for educational purposes and as a 
demonstration of Novaduino® technology only.   Nova Radio Technologies assumes no liability for any 
use or misuse of this educational product. The Environmental Sensor Kit is strictly for personal, non-
commercial, and instructional use. 
 
*We do not guarantee the Accuracy of the ENS160 sensor nor the BME280 sensor. Please see the 
manufacturers data sheets for these sensors for information on their accuracy and how to calibrate 
them. We offer some calibration variables in the open-source code for this Environmental Sensor purely 
as educational information and we do not guarantee their effectiveness nor their accuracy. 
 
*The 3D print files for the Novaduino® Environmental Sensor Demonstration Kit includes STL files for the 
Front Bezel, the Vented Case, the Sensor Enclosure, and the Faceplate/Front Panel with 3 buttons and 
rotary encoder. These files as well as additional files may be sold for a small fee and are for your limited 
personal use only. The 3D print file kit also includes the Faceplate STL, STP and F3D files so that you can 
customize the front panel however you like. 
 
* These are Trademarks for Arduino, Adafruit Industries, Feather, SparkFun Electronics, Thing Plus, ARM 
Cortex, Hammond, 4D Systems, etc… 
 
*Novaduino® is a registered trademark of Nova Radio Labs LLC 
 
*The Novaduino® Display PCBA and Expansion Proto Card PCBA are Development Boards. They have 
been designed with lead-free components, materials, and PCB processes. They are not yet RoHS, UL, 
FCC, nor CE certified. 


